ICPC2017 Urumqi A Possible Tree

5220: A Possible Tree

时间限制: 2 Sec  内存限制: 128 MB
提交: 80  解决: 27
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Alice knows that Bob has a secret tree (in terms of graph theory) with n nodes with n − 1 weighted edges with integer values in [0, 260 −1]. She knows its structure but does not know the specific information about edge weights.
Thanks to the awakening of Bob’s conscience, Alice gets m conclusions related to his tree. Each conclusion provides three integers u, v and val saying that the exclusive OR (XOR) sum of edge weights in the unique shortest path between u and v is equal to val.
Some conclusions provided might be wrong and Alice wants to find the maximum number W such that the first W given conclusions are compatible. That is say that at least one allocation of edge weights satisfies the first W conclusions all together but no way satisfies all the first W + 1 conclusions (or there are only W conclusions provided in total).
Help Alice find the exact value of W.

 

输入

The input has several test cases and the first line contains an integer t (1 ≤ t ≤ 30) which is the number of test cases.
For each case, the first line contains two integers n (1 ≤ n ≤ 100000) and c (1 ≤ c ≤ 100000) which are the number of nodes in the tree and the number of conclusions provided. Each of the following n−1 lines contains two integers u and v (1 ≤ u, v ≤ n) indicating an edge in the tree between the u-th node and the v-th node. Each of the following c lines provides a conclusion with three integers u, v and val where 1 ≤ u, v ≤ n and val ∈ [0, 260 − 1].

 

输出

For each test case, output the integer W in a single line.

 

样例输入

2
7 5
1 2
2 3
3 4
4 5
5 6
6 7
1 3 1
3 5 0
5 7 1
1 7 1
2 3 2
7 5
1 2
1 3
1 4
3 5
3 6
3 7
2 6 6
4 7 7
6 7 3
5 4 5
2 5 6

 

样例输出

3
4

题目是说给你一课树,然后每次给你两个点之间的所有边的亦或和的值,让你判断前面多少个给的信息是正确的。

其实答案和给的树并没有关系,用带权并查集维护一下一个点到他的祖先点的距离的亦或和。每次读入两个点和他们之间的距离的亦或和,如果和现有的并查集里的数据发生冲突了,则得到了结果,否则把新读入的两点之间的距离的亦或和存入并查集。

#include <bits/stdc++.h>
#include <ext/rope>
using namespace std;
typedef long long ll;
int n,c;
const int maxn = 100005;
int f[maxn];
ll vxor[maxn];
void init()
{
    for (int i = 0; i <= n; i++)
        f[i] = i;
    memset(vxor, 0, sizeof(vxor));
}
int findd(int x)
{
    if (f[x] == x)
        return f[x];
//    vxor[x] ^= vxor[f[x]];
    ll tmp = f[x];
    f[x] = findd(f[x]);
    vxor[x] ^= vxor[tmp];
    return f[x];
}
int main()
{
//    freopen("in.txt","r",stdin);
    int t,x,y,ans;
    scanf("%d", &t);
    while (t--)
    {
        ll w;
        scanf("%d%d", &n, &c);
        ans = c;
        init();
        for (int i = 1; i < n; i++)
            scanf("%d%d", &x, &y);
        scanf("%d%d%lld", &x, &y, &w);
        int fx = findd(x);
        int fy = findd(y);
        f[fx] = fy;
        vxor[fx] = vxor[x] ^ vxor[y] ^ w;
        for (int i = 1; i < c; i++)
        {
            scanf("%d%d%lld", &x, &y, &w);
            fx = findd(x);
            fy = findd(y);
            if (fx == fy && (vxor[x] ^ vxor[y]) != w)
            {
                ans = i;
                for (; i < c - 1; i++) //把剩余的数据读完
                    scanf("%d%d%lld", &x, &y, &w);
                break;
            }
            f[fx] = fy;
            vxor[fx] = vxor[x] ^ vxor[y] ^ w;
        }
        printf("%d\n", ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值