HDU 5355 Cake

Cake

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1160    Accepted Submission(s): 157
Special Judge


Problem Description
There are  m  soda and today is their birthday. The  1 -st soda has prepared  n  cakes with size  1,2,,n . Now  1 -st soda wants to divide the cakes into  m  parts so that the total size of each part is equal. 

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the  m  parts. Each cake must belong to exact one of  m  parts.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains two integers  n  and  m   (1n105,2m10) , the number of cakes and the number of soda.
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.
 

Output
For each test case, output "YES" (without the quotes) if it is possible, otherwise output "NO" in the first line.

If it is possible, then output  m  lines denoting the  m  parts. The first number  si  of  i -th line is the number of cakes in  i -th part. Then  si  numbers follow denoting the size of cakes in  i -th part. If there are multiple solutions, print any of them.
 

Sample Input
  
  
4 1 2 5 3 5 2 9 3
 

Sample Output
  
  
NO YES 1 5 2 1 4 2 2 3 NO YES 3 1 5 9 3 2 6 7 3 3 4 8
 

Source
 

Recommend
wange2014

题意:给你n块蛋糕,重量分别是1,2,……n-1,n;分给m个人,每个人得到的重量相同;

解法:跟square那题一样,直接深搜,可能会爆栈,开头加上#pragma comment(linker, "/STACK:102400000,102400000") 就好了。

注意:n最大为10的五次,n^2会爆int,要用__Int64.

代码:

#pragma comment(linker, "/STACK:102400000,102400000")
#include <stdio.h>
#include <string.h>
int n, m;
int p;
int vis[111111];
int ans[11][111111];
int num[11];
int now[111111];
int dfs(int bian,int len,int s) 
{                                              
    if(bian==m-1)   
        return 1;
    for(int i=s;i<=n;i++)
    {
        if(!vis[i])
        {
            vis[i]=1;
            if(len+now[i]<p)
            {
                if(dfs(bian,len+now[i],i+1))  
                {        
                        ans[bian][num[bian]++] = now[i]; 
                        return 1;
                }
            }
            else if(len+now[i]==p)
            {
                if(dfs(bian+1,0,0))  
                {
                    ans[bian][num[bian]++] = now[i];
                    return 1;
                }
            }
            vis[i]=0;
        }
    }
    return 0;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        
        memset(vis,0,sizeof(vis));
        memset(num,0,sizeof(num));
        memset(ans,0,sizeof(ans));
        scanf("%d%d", &n, &m);
        for(int i = 0;i < n;i++)
            now[i] = n - i;
        __int64 sum = (__int64)(1 + n) * n / 2;
        p = sum / m;
        if(sum%m!=0)
        {
            printf("NO\n");
            continue;
        }
        else
        {
            if(dfs(0,0,0))
            {
                printf("YES\n");
                int temp = 0;
                for(int i = 0;i< m - 1;i++)
                {
                    printf("%d",num[i]);
                    temp += num[i];
                    for(int j = 0;j<num[i];j++)
                        printf(" %d",ans[i][j]);
                    printf("\n");    
                }
                temp = n - temp;
                printf("%d",temp);
                for(int i = 0;i < n;i++)
                    if(!vis[i])
                        printf(" %d",now[i]);
                printf("\n");        
            }
            else
            {
                printf("NO\n");
            }
        }
    }
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值