HDU 5355 Cake (构造+简单回溯)

Cake

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 3255    Accepted Submission(s): 689
Special Judge


Problem Description
There are m soda and today is their birthday. The 1-st soda has prepared n cakes with size 1,2,,n. Now 1-st soda wants to divide the cakes into m parts so that the total size of each part is equal.

Note that you cannot divide a whole cake into small pieces that is each cake must be complete in the m parts. Each cake must belong to exact one of m parts.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains two integers n and m (1n105,2m10), the number of cakes and the number of soda.
It is guaranteed that the total number of soda in the input doesn’t exceed 1000000. The number of test cases in the input doesn’t exceed 1000.
 

Output
For each test case, output "YES" (without the quotes) if it is possible, otherwise output "NO" in the first line.

If it is possible, then output m lines denoting the m parts. The first number si of i-th line is the number of cakes in i-th part. Then si numbers follow denoting the size of cakes in i-th part. If there are multiple solutions, print any of them.
 

Sample Input
 
 
4 1 2 5 3 5 2 9 3
 

Sample Output
 
 
NO YES 1 5 2 1 4 2 2 3 NO YES 3 1 5 9 3 2 6 7 3 3 4 8
 

Author
zimpha@zju
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   6297  6296  6295  6294  6293 
#include <algorithm>
#include <iostream>
#include<vector>
#include<cstring>
#include<stdio.h>
#define maxn 100005
using namespace std;
long long  n,m,tar,res,tim;
int vis[maxn],plan[maxn];
vector<int> ans[100];
/*
分配的构造技巧,
刚开始想用贪心的后来无疑被wrong,
然后这题输入和数据范围上都要预判一下,
最好直接用long  long拉倒。

 参考了网上的思路,
 对其进行分组构造,
 每2*m个构成一组,对每组进行取值,
 可以构造出m个相同的大小。
 
 最后的回溯区间应该是4*m,
 。。。暂且还不知道为什么。。。
*/
bool dfs(int pos,int ss,int mm)
{
    if(mm==m)   return  true;
    for(int i=res;i>=pos;i--)
    {
        if(vis[i]==1) continue;
        if(ss+i==tar)
        {
            plan[i]=mm;
            //ans[mm].push_back(i);
            vis[i]=1;
            if( dfs(1,0,mm+1) ) return true;
            vis[i]=0;
            //ans[mm].pop_back();
        }
        else if(ss+i<tar)
        {
            vis[i]=1;
            plan[i]=mm;
            //ans[mm].push_back(i);
            if(dfs(i,ss+i,mm)) return true;
            vis[i]=0;
            //ans[mm].pop_back();
        }
    }
    return false;
}

int main()
{
    ios::sync_with_stdio(false);
    int t;scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        memset(plan,0,sizeof(plan));
        scanf("%ld%ld",&n,&m);
        if(  (n*(n+1)/2) %m!=0 )
        {
            printf("NO\n");
           continue;
        }
           long long s=n*(n+1)/2;
           tar=s/m;
           if(tar<n)
           {
               puts("NO");
               //cout<<"NO"<<endl;
               continue;
           }
           res=n%(2*m);
           if(res!=0)
           {
               res=res+2*m;
               res=min(res,n);
           }
           for(int i=n;i>res;i-=2*m)
           {
               int rb=i,lb=rb-2*m+1,tmp=0;
               tar-=(lb+rb);
               while(lb<=rb)
               {
                   ans[tmp].push_back(lb);
                   ans[tmp++].push_back(rb);
                   lb++,rb--;
               }
            }
            puts("YES");
            dfs(1,0,0);
            for(int i=1;i<=res;i++)
                 ans[plan[i]].push_back(i);
            for(int i=0;i<m;i++)
            {
                long long  tmp=ans[i].size();
                printf("%d",tmp);
                for(int j=0;j<tmp;j++)
                    printf(" %d",ans[i][j]);
                puts("");
            }
       for(int i=0;i<=m;i++) ans[i].clear();
     }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值