数据结构实验之二叉树五:层序遍历

数据结构实验之二叉树五:层序遍历

 Statistic

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Sample Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,

Sample Output

abcdefg
xnuli

Hint

 

Source

xam

 

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int l ;
char s[51];

struct node  //树节点的创立
{
    char data;
    struct node *left , *right;
};

struct node *creat()   //(有返回值的建立二叉树)
{
    char c = s[l++];
    struct node *root;
    if (c == ',')
    {
        return NULL;
    }
    else
    {
        root = (struct node *)malloc(sizeof (struct node ));
        root ->data = c;
        root ->left = creat();
        root ->right = creat();
    }
    return root;
};

void midd(struct node *root)  //中序遍历
{
    if (root)
    {
        midd(root ->left);
        printf("%c" , root->data);
        midd(root ->right);
    }
}

void hou(struct node *root) // 后序遍历
{
    if (root)
    {
        hou(root ->left);
        hou(root ->right);
        printf("%c" , root ->data);
    }
}

int leave(struct node *root) // 叶子结点的查找(叶子结点即为出度为0的节点)
{
    if (root == NULL)
    {
        return 0;
    }
    else if (root ->left == NULL && root ->right == NULL)
    {
        return 1;
    }
    else
    {
        return leave(root ->left) + leave(root ->right);
    }
}

int deth(struct node *root) // 树的高度
{
    if (root == NULL)
    {
        return 0;
    }
    else
    {
        int maxleft = deth(root ->left) , maxright = deth(root ->right);
        if (maxleft > maxright)
        {
            return 1 + maxleft;
        }
        else
        {
            return 1 + maxright;
        }
    }
}

int main()
{
    struct node *root;
    while(~scanf("%s" , s))
    {
        l = 0;
        root = (struct node *)malloc(sizeof (struct node ));
        root = creat();
        midd(root);
        printf("\n");
        hou(root);
        printf("\n");
        int k ;
        k = leave(root);
        printf("%d\n" , k);
        k = deth(root);
        printf("%d\n", k);

    }
    return 0;
}
 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值