POJ 3624 Charm Bracelet 动态规划(01背包问题)

                                                                                                                                    Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15203 Accepted: 6950

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

 

//POJ3624 01背包问题 
#include<stdio.h>
#include<string.h>
/*注意数组要开大,然后输入不需要判断EOF 
Input: 
4 6
1 4
2 6
3 12
2 7
动态规划表:
  0  1  2  3  4  5  6
0 0  0  0  0  0  0  0
1 0  4  4  4  4  4  4
2 0  4  6 10 10 10 10
3 0  4  6 12 16 18 22 
4 0  4  7 11 13 19 23
*/
int W[20000],D[20000],f[20000];
int main()
{
   int N,M;
   int i,j;
   scanf("%d%d",&N,&M);
    memset(W,0,sizeof(W));
     memset(D,0,sizeof(D));
     memset(f,0,sizeof(f));
     for(i=1;i<=N;i++)
         scanf("%d%d",&W[i],&D[i]);
     for(i=0;i<=M;i++)  f[i]=0;
        
     for(i=1;i<=N;i++)
       for(j=M;j>=W[i];j--)
       {
         if(f[j]<(f[j-W[i]]+D[i])) f[j]=f[j-W[i]]+D[i]; 
       }          
     printf("%d\n",f[M]);
   return 0; 
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值