暑假集训第三周周三赛 STL A - So easy 判断集合


A - So easy
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Small W gets two files. There are n integers in each file. Small W wants to know whether these two files are same. So he invites you to write a program to check whether these two files are same. Small W thinks that two files are same when they have the same integer set. 
For example file A contains (5,3,7,7),and file B contains (7,5,3,3). They have the same integer set (3,5,7), so they are same. 
Another sample file C contains(2,5,2,5), and file D contains (2,5,2,3). 
The integer set of C is (2,5),but the integer set of D is (2,3,5),so they are not same. 
Now you are expected to write a program to compare two files with size of n.
 

Input

Multi test cases (about 100). Each case contain three lines. The first line contains one integer n represents the size of file. The second line contains n integers $a_1, a_2, a_3, \ldots, a_n$ - represents the content of the first file. The third line contains n integers $b_1, b_2, b_3, \ldots, b_n$ - represents the content of the second file. 
Process to the end of file. 
$1 \leq n \leq 100$ 
$1 \leq a_i , b_i \leq 1000000000$
 

Output

For each case, output "YES" (without quote) if these two files are same, otherwise output "NO" (without quote).
 

Sample Input

     
     
3 1 1 2 1 2 2 4 5 3 7 7 7 5 3 3 4 2 5 2 3 2 5 2 5 3 1 2 3 1 2 4

Sample Output

   
   
YES YES NO NO
分析:

可能昨天就是心情不好吧,提都不想做,就这一道都是好不容易才做的。

这题就是找他们的集合是不是相同,所以要用set

它的作用主要就是去重,排序,如果经过处理后他们的集合一样,就输出YES

set只有一个自变量,所以没有first或second,只能用*p1!=*p2

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
#include<stdio.h>
#include<algorithm>
#include<set>
using namespace std;
int main()
{
    int n,a,i,f;
    set<int>s1,s2;
    while(scanf("%d",&n)!=EOF)
    {
        s1.clear();
        s2.clear();
        for(i=0; i<n; i++)
        {
            scanf("%d",&a);
            s1.insert(a);
        }
        for(i=0; i<n; i++)
        {
            scanf("%d",&a);
            s2.insert(a);
        }
        if(s1.size()!=s2.size())
            printf("NO\n");
        else
        {
            f=0;
            set<int>::iterator p1,p2;
            for(p1=s1.begin(),p2=s2.begin(); p1!=s1.end()&&p2!=s2.end(); p1++,p2++)

                if(*p1!=*p2)
                {
                    f=1;
                    break;
                }
            if(f==0)
                printf("YES\n");
            else
                printf("NO\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值