暑假集训第三周周三赛 STL E - Gunner 射鸟



E - Gunner
Time Limit:4000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Long long ago, there is a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are $n$ birds and $n$ trees. The $i-th$ bird stands on the top of the $i-th$ tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the bird which stands in the tree with height $H$ will falls. 
Jack will shot many times, he wants to know how many birds fall during each shot. 

a bullet can hit many birds, as long as they stand on the top of the tree with height of $H$.
 

Input

There are multiple test cases (about 5), every case gives $n,m$ in the first line, $n$ indicates there are $n$ trees and $n$ birds, $m$ means Jack will shot $m$ times. 

In the second line, there are $n$ numbers $h[1],h[2],h[3],…,h[n]$ which describes the height of the trees. 

In the third line, there are m numbers $q[1],q[2],q[3],…,q[m]$ which describes the height of the Jack’s shots. 

Please process to the end of file. 

[Technical Specification] 

$1 \leq n,m \leq 1000000(10^{6})$ 

$1 \leq h[i],q[i] \leq 1000000000(10^{9})$ 

All inputs are integers.
 

Output

For each $q[i]$, output an integer in a single line indicates the number of birds Jack shot down.
 

Sample Input

     
     
4 3 1 2 3 4 1 1 4
 

Sample Output

     
     
1 0 1

分析:

本题用到一个find()函数,它也是遍历,但它只能遍历找到一个数据,而迭代器是找到所有数据

比如 3 3 find只能输出一个,而迭代器可以输出两个


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
#include<stdio.h>
#include<map>
using namespace std;
int main()
{
    int m,n,a,b,i;

    while(scanf("%d %d",&m,&n)!=EOF)
    {
        map< int,int > p;
        for(i=0;i<m;i++)
        {
            scanf("%d",&a);
            p[a]++;
        }
        for(i=0;i<n;i++)
        {
            scanf("%d",&b);
            if(p.find(b)!=p.end())
            {
                printf("%d\n",p[b]);
                p.erase(b);
            }
            else
                printf("0\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值