暑假集训第四周阶段二E - Max Sum最大连续子数组和


E - Max Sum
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

     
     
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

     
     
Case 1: 14 1 4 Case 2: 7 1 6
分析:

这个是最大子数组和的变形,就是多了一个条件,必须连续

只需当s<0的时候,把s重新置为0就可以了,然后重新连续计算

当当前的计算值不大于最大值时不用管它,最后输出最大值就好


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include<stdio.h>
 int t,n,v[100010],a,b,m;
 int f(int v[] )
 {   int c=0,d=1,i;
     for(i=0;i<n;i++)
      {
          c+=v[i];
        if(c>m)
        {
            m=c;
            a=d;
            b=i+1;
        }
        if(c<0)
        {
            c=0;
            d=i+2;
        }
      }
     return m;
 }
int main()
{
   scanf("%d",&t);
   int i,j;

   for(i=1;i<=t;i++)
   {
       a=0,b=n-1,m=-10000010;
       scanf("%d",&n);
       for(j=0;j<n;j++)
        scanf("%d",&v[j]);
       m=f(v);
       printf("Case %d:\n",i);
       printf("%d %d %d\n",m,a,b);
       if(i!=t)
        printf("\n");
   }
   return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值