Description
Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.
FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.
Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.
Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.
Input
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
Output
Sample Input
3 8 5 8
Sample Output
34
Hint
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
分析:
对所输入的数据构造Huffman树,其中非叶子节点的值加起来的和为所求。
Huffman树的构造过程: 每次取所有数中的两个最小数,相加起来得到一个非叶子节点的值,下次取的时候以前取过的两个最小数数不能再取,再相加得到非叶子节点的值可以取。
比如 3 , 4 , 5 ,先取 3 ,4 相加为 7 , 然后取 5 ,7(3,4取过不能再取了),相加为12, 7+12 =19,即为所求。
优先队列可以很好的实现这个操作。
#include<stdio.h>
#include<string>
#define INF 0x3f3f3f3f
#include<algorithm>
#include<queue>
using namespace std;
int main()
{
int i,j,n,a[50010];
priority_queue<int,vector<int>,greater<int> >q;//大顶堆
// priority_queue<int,vector<int>,less<int> >q;//小顶堆
scanf("%d",&n); //优先队列自带排序,大顶堆默认从小向大排,小顶堆从小到大
for(i=0; i<n; i++)
{
scanf("%d",&a[i]);
q.push(a[i]);
}
long long s=0;
while(!q.empty())
{
int n1=q.top();//找到两个最小的作为孩子
q.pop();
int n2=q.top();
q.pop();
s+=n1+n2; //把双亲节点的值相加
if(q.empty())
break;
q.push(n1+n2);//把双亲节点放入队列,重新组合
}
printf("%I64d\n",s);
return 0;
}