poj 1274最喜欢的畜栏(最大流)

Description

Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall. 
Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible. 

Input

The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

Output

For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

Sample Input

5 5
2 2 5
3 2 3 4
2 1 5
3 1 2 5
1 2 

Sample Output

4

分析:

这是关于最大流的问题,其中的增广路还是不太懂,先放放,等多了解了解流的知识再进一步解释

增广路的定义(也称增广轨交错轨):

若P是图G中一条连通两个未匹配顶点的路径,并且属于M的边和不属于M的边(即已匹配和待匹配的边)在P上交替出现,则称P为相对于M的一条增广路径(举例来说,有A、B集合,增广路由A中一个点通向B中一个点,再由B中这个点通向A中一个点……交替进行)。

由增广路的定义可以推出下述三个结论:

1-P的路径长度必定为奇数,第一条边和最后一条边都不属于M。

2-不断寻找增广路可以得到一个更大的匹配M’,直到找不到更多的增广路。

3-M为G的最大匹配当且仅当不存在M的增广路径。

4-最大匹配数M+最大独立数N=总的结点数  

增广路主要应用于匈牙利算法中,用于求二分图最大匹配

#include<stdio.h>
#include<string.h>
int m,n,q[220][220],l[220],v[210];
int  dfs(int m)//从左边开始找增广路径
{
    int i;
    for(i=0; i<n; i++)//定点编号从0开始
        if(q[m][i]&&!v[i])//如果左右顶点连通,且右顶点位使用
        {
            v[i]=1;//标记为已用
            if(l[i]==-1||dfs(l[i]))//找增广路
            {
                l[i]=m;//标记
                return 1;//返回真
            }
        }
    return 0;
}
int hungary()
{
    int r=0,i;
    memset(l,-1,sizeof(l));
    for(i=0; i<m; i++)
    {
        memset(v,0,sizeof(v));
        if(dfs(i))//
            r++;
    }
    return r;
}
int main()
{
    int x,y,i,j,k;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(q,0,sizeof(q));
        for(i=0; i<m; i++)
        {
            scanf("%d",&x);
            for(j=0; j<x; j++)
            {
                scanf("%d",&k);
                q[i][k-1]=1;//下标从0开始的
            }
        }
        printf("%d\n",hungary());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值