杭电OJ-- 2095 find your present (依然很水)

Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded

可怜可怜题目不难,要注意控制一下内存,内存不要超出即可。开始时准备使用multiset,结果发现超出了内存,后来直接用数组了,后来改用map来做。

安静安静map中存储<num,index>对,num表示礼品的编号,index表示该编号对应数组的下标。总之自己看代码吧,这道题也很水。

鄙视鄙视代码如下:

/*
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <set>
using namespace std;

//const int MAX_NUM = 1000000;

int main()
{
	multiset<int> num_set;
	int num;
	while (cin >> num && num != 0)
	{
		//int numOfPresent[MAX_NUM];
		//memset(numOfPresent, 0, sizeof(numOfPresent));
		int present_num;
		num_set.clear();
		for (int i = 0; i < num; ++i)
		{
			scanf("%d", &present_num);
			num_set.insert(present_num);
		}
		multiset<int>::iterator set_it = num_set.begin();

		for (; set_it != num_set.end(); ++set_it)
		{
			if (num_set.count(*set_it) % 2)
			{
				cout << *set_it << endl;
				break;
			}
		}


	}
	return 0;
}
*/
/*使用set不太现实,因为内存会超出限制*/
#define _CRT_SECURE_NO_WARNINGS
#include <iostream>
#include <map>
using namespace std;
const int MAX_NUM = 1000000;
int num_of_present[MAX_NUM];

int main()
{
	map<int, int> num_map;
	
	int num;
	while (cin >> num && num != 0)
	{
		int present_num = 0;
		int index = 0; //指针
		num_map.clear();
		memset(num_of_present, 0, sizeof(num_of_present));
		for (int i = 0; i < num; ++i)
		{
			scanf("%d", &present_num);
			map<int, int>::iterator map_it = num_map.find(present_num);
			if (map_it != num_map.end())
			{
				++num_of_present[map_it->second];
				//cout << "要插入的数字是" << present_num << endl;
				//cout << "map_it->second = " << map_it->second << endl;
				//cout << "num_of_present[map_it->second] = " << num_of_present[map_it->second] << endl;
			}
			else
			{
				//cout << "要插入的数字是" << present_num << endl;
				//cout << "map中无数据" << endl;
				//cout << "index = " << index << endl;
				num_map.insert(make_pair(present_num, index));
				++num_of_present[index];
				++index;
			}

		}
		map<int, int>::iterator map_it = num_map.begin();
		while (map_it != num_map.end())
		{
			if (num_of_present[map_it->second] % 2 != 0)
			{
				cout << map_it->first << endl;
				break;
			}
			++map_it;
		}
		
	}
	return 0;
}



杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值