(位运算)牛人的题目

(位运算)牛人的题目[swustxxoj1017]

题目:

In the new year party, everybody will get a “special present”.Now it’s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present’s card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

输入:

The input file will consist of several cases.
Each case will be presented by an integer n (1 <= n <= 1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.

输出:

For each case, output an integer in a line, which is the card number of your present.

样例输入:

5
1 1 3 2 2
3
1 2 1
0

样例输出:

3
2

题意:

输入N个数,假设有且只有一个数只出现奇数次,那么请找出这个数并输出。

分析:

先了解下位运算异或,异或运算符”∧”,如果p、q两个值不相同,则异或结果为1。如果p、q两个值相同,异或结果为0。
即:

pqp^q
000
011
101
110

并且我们可以通过异或运算不借助另一个临时变量交换两个变量的值,即:
a = a∧b;
b = b∧a;
a = a∧b;
详解:
我们设a1=a^b;
b^a1=b^(a^b)=(b^b)^a=0^a=a;
a1=a1^b=(a^b)^a=(a^a)^b=0^b=b;
由此可得:
a^b^b=a;
0^a=a;
所以我们可以用异或运算来做这道题目,即先设ans=0,然后与输入的值进行异或运算,所有出现偶数次的数与ans进行异或运算后得到的值还是ans,所以最后得到的ans即为那个只出现奇数次的数。

代码:

#include<stdio.h>
const int inf=99999999;
using namespace std;

int main()
{
	int n,i;
	while(~scanf("%d",&n) && n!=0)
	{
		int ans=0,a;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a);
			ans^=a;
		}
		printf("%d\n",ans);
	}
	return 0;
}

  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值