Edge
Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.
Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.
You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.
You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.
Sample Input
V AVV
Sample Output
300 420 moveto 310 420 lineto 310 430 lineto stroke showpage 300 420 moveto 310 420 lineto 310 410 lineto 320 410 lineto 320 420 lineto stroke showpage
Source
这篇文章的题意我算是服了,看了半天愣是没有看懂。
其实就是个水题。
A是右转,V是左转。。。。初始坐标是300,420,每次走10。。。。。。模拟就可以了,四个走向。
A是右转,V是左转。。。。初始坐标是300,420,每次走10。。。。。。模拟就可以了,四个走向。
代码如下:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int SIZE = 250;
int main()
{
char str[SIZE];
char flag;
while (scanf ("%s", &str) != EOF)
{
int x = 310, y = 420;
int len = strlen(str);
printf("300 420 moveto\n310 420 lineto\n");
flag = 'r'; /*刚开始的时候向右,即x轴正方向*/
for (int i = 0; i < len; i++)
{
switch (flag)
{
case 'r': if (str[i] == 'A') {y = y - 10; flag = 'd';} else {y = y + 10; flag = 'u';} break;
case 'd': if (str[i] == 'A') {x = x - 10; flag = 'l';} else {x = x + 10; flag = 'r';} break;
case 'l': if (str[i] == 'A') {y = y + 10; flag = 'u';} else {y = y - 10; flag = 'd';} break;
case 'u': if (str[i] == 'A') {x = x + 10; flag = 'r';} else {x = x - 10; flag = 'l';} break;
}
printf("%d %d lineto\n", x, y);
}
printf("stroke\nshowpage\n");
}
system ("pause");
return 0;
}