HDU——1033 Edge

Problem Description

For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input

The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output

For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input

V
AVV

Sample Output

300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage

解题思路:

水题,读懂题目是关键。
题目大意:类似于在一个坐标轴上,从初始点(300 , 420)开始画图,每次画图是沿当前方向前进 10 个单位;接着,根据输入的字符来转个方向,继续前进 10 个单位;以此类推,转弯,前进,转弯,前进······
其中方向控制字符 A-表示顺时针方向旋转90度 V-表示逆时针方向循转90度。

注:控制方向旋转的同时要尤其之一当前 前进的方向 , 因为当前前进方向的不同会导致x,y有不同的变化(这点可以自己画图看一下)。

代码:

#include <stdio.h>
#include <string.h>
using namespace std;

char dir[201];
int main(){
    int x , y,len = 0 , direction;  //direction表示当前的前进方向(1-向右 , 2-向下 , 3-向左 , 4-向上)
    while(scanf("%s",dir) != EOF){
        x = 300 ;
        y = 420;
        direction = 1;
        len = strlen(dir);
        printf("%d %d moveto\n",x,y);
        x = x + 10;
        for(int i = 0 ; i < len ; i ++){
            switch(direction){
                case 1:if(dir[i] == 'V'){
                            printf("%d %d lineto\n",x ,y);
                            y = y + 10;
                            direction = 4;
                        }else if(dir[i] == 'A'){
                            printf("%d %d lineto\n",x ,y);
                            y = y - 10;
                            direction = 2;
                        }
                        break;
                case 2:if(dir[i] == 'V'){
                            printf("%d %d lineto\n",x ,y);
                            x = x + 10;
                            direction = 1;
                        }else if(dir[i] == 'A'){
                            printf("%d %d lineto\n",x ,y);
                            x = x - 10;
                            direction = 3;
                        }
                        break;
                case 3:if(dir[i] == 'V'){
                            printf("%d %d lineto\n",x ,y);
                            y = y - 10;
                            direction = 2;
                        }else if(dir[i] == 'A'){
                            printf("%d %d lineto\n",x ,y);
                            y = y + 10;
                            direction = 4;
                        }
                        break;
                case 4:if(dir[i] == 'V'){
                            printf("%d %d lineto\n",x ,y);
                            x = x - 10;
                            direction = 3;
                        }else if(dir[i] == 'A'){
                            printf("%d %d lineto\n",x ,y);
                            x = x + 10;
                            direction = 1;
                        }
                        break;
            }
        }
        printf("%d %d lineto\n",x ,y);
        printf("stroke\nshowpage\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值