hdu 1068 二分图 最大独立集

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 …
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0
Output
5
2
Sample Input
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0
Sample Output
5
2

题意:有n个人,一些人认识另外一些人,选取一个集合,使得集合里的每个人都互相不认识,求该集合中人的最大个数。
题解:这题就是求最大独立集,但是这并不是两个集合,而是一个集合,所以求出最大匹配后需要/2,然后代公式:最大独立集=N-最大匹配。

#include <bits/stdc++.h>
using namespace std;

const int N = 1010;
int n,m,f[1010];
bool vis[1010];
vector<int> v[1010];

int dfs(int i)
{
    vis[i]=1;
    for(int j=0;j<v[i].size();j++)
    {
        if(f[v[i][j]]==-1||(!vis[ f[v[i][j]] ]&&dfs(f[v[i][j]])))
        {
            f[v[i][j]]=i;
            f[i]=v[i][j];
            return 1;
        }
    }

    return 0;

}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(f,-1,sizeof(f));
        for(int i=0;i<n;i++)
            v[i].clear();
        for(int i=0;i<n;i++)
        {
            int k,x;
            scanf("%d: (%d)",&k,&x);
            for(int j=0;j<x;j++)
            {
                int d;
                scanf("%d",&d);
                v[k].push_back(d);
            }
        }
        int cnt=0;
        for(int i=0;i<n;i++){
            if(f[i]==-1)
            {
                memset(vis,0,sizeof(vis));
                cnt+=dfs(i);
            }
        }
        printf("%d\n",n-cnt);
    }

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值