hdoj 1379 DNA Sorting【排序】

DNA Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2231    Accepted Submission(s): 1096


Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. 
 

Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file. 
 

Sample Input
  
  
1 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
 

Sample Output
  
  
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA
 

Source
 

题意:

DAABEC的长度为 5 ,D比它右边的4个字符都大 、E比它右边1个字符大,逆序即为长度。

输出按长度从小到大,如果长度一样,按出现先后顺序输出。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    char s[55];
    int appear,len;
}p[111];
bool cmp( node a,node b)//排序,如果长度不同按长度排序,否则按出现先后排序 
{
    if( a.len!=b.len )
        return a.len < b.len ;
    return a.appear < b.appear;
}
int main()
{
    int n, m, t, i, j, k;
    scanf("%d",&t);
    while( t-- )
    {
        scanf("%d%d",&n,&m);//n字符串长度,m行数 
        for( i = 0; i < m; i++ )
        {
            scanf("%s",p[i].s);//输入字符串 
            int lenth = 0;//记录长度,所以先初始化为0 
            for( j = 0 ;j < n ;j++)
            {
                for( k = j+1; k < n ;k++ )//用两层for循环,遍历求lenth 
                {
                    if( p[i].s[j] > p[i].s[k] )//逐项比较 
                    lenth++;
                }
            }
            p[i].len=lenth;//存进结构体 
            p[i].appear=i;//记录出现先后 
        }
        sort( p, p+m ,cmp );//排序 
        for( i = 0; i < m ;i++)
        printf("%s\n",p[i].s);
        if( t != 0)    printf("\n"); /*如果不止一种情况,两种情况之间有空行,
		最后没有空行,缺少此句会导致 PE.*/ 
    }
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值