ACM--字母排序--HDOJ 1379--DNA Sorting--字符串


HDOJ题目地址:传送门



DNA Sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3100    Accepted Submission(s): 1538


Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. 
 

Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file. 
 

Sample Input
  
  
1 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT
 

Sample Output
  
  
CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA

题意: 计算每一个字符串的等级 ,在进行排序  ,等级相同,按原顺序输出 

计算等级规则,例如:AACATGAAGG   :

                  C 大于其后面的 3 个 A ,T 大于其后面的 5 个字符 ,第一个 G 大于其后面的 2 个 A,  字符串等级为  10


#include<stdio.h>
#include<string.h>
#include<map>
#include<iostream>
#include<algorithm>
using namespace std;
int get(string s){
    int result=0;
    int temp;
    for(int i=0;i<s.size();i++){
        for(int j=(i+1);j<s.size();j++){
            temp=(s[i]-'0')-(s[j]-'0');
            if(temp>0){
                result++;
            }
        }
    }
    return result;
}
int main(){
   int t;
   cin>>t;
   getchar();
   getchar();
   while(t--){
     map<int,string> ma;
     int flag[110];
     int n,m;
     int index=0;
     int temp;
     string s;
     scanf("%d%d",&n,&m);
     getchar();
     for(int i=0;i<m;i++){
        getline(cin,s);
        temp=get(s);
        ma[temp]=s;
        flag[index++]=temp;
     }
     sort(flag,flag+index);
     int a;
     for(int f=0;f<index;f++){
        a=flag[f];
        cout<<ma[a]<<endl;
     }

   }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值