hdoj 2660 Accepted Necklace【DFS】

Accepted Necklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3141    Accepted Submission(s): 1217


Problem Description
I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won't accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
 

Input
The first line of input is the number of cases. 
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace. 
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight. 
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000. 
 

Output
For each case, output the highest possible value of the necklace.
 

Sample Input
  
  
1 2 1 1 1 1 1 3
 

Sample Output
  
  
1
 

很有意思的一道搜索题,处理不好的话会超时。
#include<stdio.h>
struct node{
	int v,w; 
}p[22]; 
int n,k,v,w,a,t,sum;
void dfs(int v,int w,int z,int j)//4个参数  依次是 价值 重量 合格宝石数量  j控制时间已经搜索过的不再判断 
{
	if(w > a|| z > k)	return;//如果重量不符合或者合格个数超过限制--结束 
	if(sum < v)	sum = v;//价值最高 
	for(int i = j; i < n;i++)
	dfs(v+p[i].v, w+p[i].w, z+1,i+1);
}
int main()
{
	scanf("%d",&t);
	while(t--)
	{
		sum = 0;
		scanf("%d%d",&n, &k);// n块宝石,其中 k 块可以做成项链 
		for(int i = 0; i < n; i++)
		scanf("%d%d",&p[i].v,&p[i].w);
		scanf("%d", &a );//项链重量限制 
		dfs(0,0,0,0);
		printf("%d\n",sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值