hdoj 2955 Robberies【01背包】【dp】

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17391    Accepted Submission(s): 6435


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
  
  
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
  
  
2 4 6

Mj是背包体积, Pj 是背包价值~

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
const int inf = 0x3f3f3f;
double dp[20000];
struct node{
	int v;//背包  体积 
	double val;// 背包价值 
};
node p[1200];
int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		int i,j,k,n;
		double a;
		scanf("%lf%d", &a, &n);//被抓概率,n个银行 
		a = 1-a;//成功逃脱概率 
		for(i = 1, k = 0; i <= n; i++)
		{
			scanf("%d%lf", &p[i].v, &p[i].val);
			k += p[i].v;//背包总体积 
			p[i].val = 1-p[i].val;//把被抓几率都转换成逃脱概率  
		}
		for(i = 1; i <= k; i++)
			dp[i] = -1;
		dp[0] = 1;//一分钱不抢 不被抓 逃脱概率100% 
		for(i = 0; i <= n; i++)
		{
			for(j = k; j >= p[i].v; j--)
			{
				dp[j] = max(dp[j], dp[j-p[i].v]*p[i].val);//抢成功时 概率相乘 并求最大值 
			}
		}
		for(  ; k >= 0; k--)
		{
			if(dp[k] >= a)
				break;//直到逃脱概率到最低限度时退出循环 成功抢到最多的钱且不被抓 
		}
		printf("%d\n", k);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值