hdoj 5625 Clarke and chemistry

Clarke and chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 273    Accepted Submission(s): 153



Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a junior student and took a chemistry exam. 
But he did not get full score in this exam. He checked his test paper and found a naive mistake, he was wrong with a simple chemical equation balancer. 
He was unhappy and wanted to make a program to solve problems like this. 
This chemical equation balancer follow the rules: 
Two valences  A  combined by  |A|  elements and  B  combined by  |B|  elements. 
We get a new valence  C  by a combination reaction and the stoichiometric coefficient of  C  is  1 . Please calculate the stoichiometric coefficient  a  of  A  and  b  of  B  that  aA+bB=C,  a,bN .
 

Input
The first line contains an integer  T(1T10) , the number of test cases. 
For each test case, the first line contains three integers  A,B,C(1A,B,C26) , denotes  |A|,|B|,|C|  respectively. 
Then  A+B+C  lines follow, each line looks like  X c , denotes the number of element  X  of  A,B,C  respectively is  c . ( X  is one of  26  capital letters, guarantee  X  of one valence only appear one time,  1c100 )
 

Output
For each test case, if we can balance the equation, print  a  and  b . If there are multiple answers, print the smallest one,  a  is smallest then  b  is smallest. Otherwise print NO.
 

Sample Input
  
  
2 2 3 5 A 2 B 2 C 3 D 3 E 3 A 4 B 4 C 9 D 9 E 9 2 2 2 A 4 B 4 A 3 B 3 A 9 B 9
 

Sample Output
  
  
2 3 NO Hint: The first test case, $a=2, b=3$ can make equation right. The second test case, no any answer.
 

Source
 


一开始处理的有问题,结构体不可行,后来看了大神的做法 用个函数 就给解决了。

我的AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
int a[30], b[30], c[30];
bool find(int x, int y)
{
	for(int k =  0; k < 26; k++)
	{
		if(x*a[k] + y*b[k] != c[k])
		return 0;
	}
	return 1;
}
int main()
{
	int t; Si(t);
	Wi(t)
	{
		mem(a, 0);mem(b, 0);mem(c, 0);
		char s[2];
		int u, v, w;
		scanf("%d%d%d", &u, &v, &w);
		int i, j, k, d;
		for(i = 0; i < u; i++)
		{
			scanf("%s%d",s, &d);
			a[s[0]-'A'] += d;
		}
		for(i = 0; i < v; i++)
		{
			scanf("%s%d",s, &d);
			b[s[0]-'A'] += d;
		}
		for(i = 0; i < w; i++)
		{
			scanf("%s%d",s, &d);
			c[s[0]-'A'] += d;
		}
		bool flag = 0;
		for(i = 1; i <= 100; i++)
		{
			for(j = 1; j <= 100; j++)
			{
				if(find(i, j))
				{
					printf("%d %d\n", i, j);
					flag = 1; break;
				}
			}
			if(flag)  break;
		}
		if(!flag)  puts("NO");
	}
	return 0;
}

宇神的思路:(二维数组存放)

AC代码:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define mem(a, b) memset(a, (b), sizeof(a))
#define Wi(a) while(a--)
#define Si(a) scanf("%d", &a)
#define Pi(a) printf("%d\n", (a))
#define INF 0x3f3f3f3f
#include<algorithm>
using namespace std;
int a[3][30];
int b[3];
bool judge(int x, int y)
{
	for(int i = 0; i <= 25; i++)
	{
		if(a[0][i]*x+a[1][i]*y != a[2][i])
			return false;
	}
	return true;
}
int main()
{
	int t;  Si(t);
	Wi(t)
	{
		mem(a, 0);
		char s[2];
		int i, j, k, d;
		for(i = 0; i < 3; i++)  Si(b[i]);
		for(i = 0; i < 3; i++)
		{
			for(j = 1; j <= b[i]; j++ )
			{
				scanf("%s%d", s, &d);
				a[i][s[0]-'A'] = d;
			}
		}
		bool flag = false;
		for(i = 1; i <= 100; i++)
		{
			for(j = 1; j <= 100; j++)
			{
				if(judge(i, j))
				{
					printf("%d %d\n", i, j);
					flag = 1;break;
				}
			}
			if(flag)  break;
		}
		if(!flag)  printf("NO\n");
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值