hdoj55464Clarke and problem【dp】

Clarke and problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 950    Accepted Submission(s): 378


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a student and read a book.
Suddenly, a difficult problem appears: 
You are given a sequence of number  a1,a2,...,an  and a number  p . Count the number of the way to choose some of number(choose none of them is also a solution) from the sequence that sum of the numbers is a multiple of  p ( 0  is also count as a multiple of  p ). Since the answer is very large, you only need to output the answer modulo  109+7
 

Input
The first line contains one integer  T(1T10)  - the number of test cases. 
T  test cases follow. 
The first line contains two positive integers  n,p(1n,p1000)  
The second line contains  n  integers  a1,a2,...an(|ai|109 ).
 

Output
For each testcase print a integer, the answer.
 

Sample Input
  
  
1 2 3 1 2
 

Sample Output
  
  
2 Hint: 2 choice: choose none and choose all.
 

Source
 
/*
dp[i][j]表示前i个数对p取模为j的方案数
则dp[i][j]即为要第i个数和不要第i个数的方案数的和
即dp[i][j]=dp[i-1][j]+dp[i-1][j-num[i]]; 
*/
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#define MOD 1000000007
using namespace std;
const int maxn=1010;
int num[maxn];
int dp[maxn][maxn];
int main()
{
	int t,i,j,n,k,p;
	scanf("%d",&t);
	while(t--){
		scanf("%d%d",&n,&p);
		for(i=1;i<=n;++i){
			scanf("%d",&num[i]);
		}
		memset(dp,0,sizeof(dp));
		dp[0][0]=1;
		for(i=1;i<=n;++i){
			for(j=0;j<p;++j){
				dp[i][j]=(dp[i-1][j]+dp[i-1][((j-num[i])%p+p)%p])%MOD;
			}
		}
		printf("%d\n",dp[n][0]);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值