poj 2406 KMP求周期数

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 41689 Accepted: 17335

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
题意:每行输入一个字符串,求这个字符串中的循环节的个数,所谓的循环节其实就是该串中具有周期性的子串。比如字符串ababab,以ab作为子串,既刚好一个周期(该主串的最小周期),主串中具有三个子串ab,既有三个循环节,说到底还是kmp中next数组的另一种应用。测试数据输入 “ . ”时结束。

具体代码:
#include <stdio.h>
#include <string.h>
char s[1000005];
int next[1000005];
void Make_next(char *s,int len)
{
	int i=0,j=-1;
	memset(next,0,sizeof(next));
	next[0]=-1;
	while(i<len)
	{
		if(j==-1 || s[i]==s[j])
		{
			i++; j++;
			next[i]=j;
		}
		else
			j=next[j];
	}
}
int main()
{
	while(scanf("%s",s) && s[0]!='.')
	{
		int len=strlen(s);
		Make_next(s,len);
		int min_repetend=len-next[len];
		//printf("%d\n",min_repetend);
		if(len%min_repetend==0)
			printf("%d\n",len/min_repetend);
		else
			printf("1\n");
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值