hud 1018 Big Number

Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 
Sample Input
  
  
2 10 20

Sample Output
  
  
7 19


题意:给定一个大数,求出这个数的阶乘的位数


解题思路:做过 nyoj 28 大数阶乘 的很容易会想到用同样的方法做这个题,但是提交往往会发现超时,因为这个题给出的测试数据明显比那个题大的多,所以此处就要改变方法了;以前在数学中我们学过,对于任意一个数n求其位数的公式为  len=(int)log10(n)+1,那么len就是这个数的位数,同样的道理,求一个数的阶乘的位数,仍然用此种方法:

例如:求10!的位数len

则len=(int)log10(10!)+1

又len=(int)log10(1*2*3*....*9*10)+1

既len=(int){log10(1)+log10(2)+......+log10(9)+log10(10)}+1

到次处,已经把10!转换成求10个数的位数的子式,利用log10(a)这个函数分别求出相应的位数即可

具体代码:
#include <stdio.h>
#include <math.h>
int main()
{
	int T,n;
	scanf("%d",&T);
	while(T--)
	{
		double len=0,i;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			len+=log10(i);
		printf("%d\n",(int)len+1);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值