Ordering Tasks

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is
only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing
two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the
number of direct precedence relations between tasks. After this, there will be m lines with two integers
i and j, representing the fact that task i must be executed before task j.
An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3

题意:按顺序输出入度为0的点。

这道题有点难以理解,小白的我看了好久,才总算明白题主要让我们做什么了。

分析:就是按照入度为0的顺序由小到大输出点,乍一看题中根本就没有给出4号点,那么4号点是从哪来的呢?其实在这种情况下就默认4号点的入度为0,所以就可以利用队列来解题了,用一个队列来存储入度为0的点,按照由小到大的顺序,那么也就可以把所有的点依次压入队列中了。

在此分享一下今天刚学到的小知识点,在for语句中用于判断的条件中含有  ||  时表示只要两侧有一个条件为真时就可以进入循环语句,同时为家时方可退出循环,而 && 则不然它就表示只要两侧的条件有一个为假时那就必须退出循环!!!

 代码如下:

#include<cstdio>
#include<vector>
#include<iostream>
#include<cstring>
#include<cmath>
#include<queue>
#include<map>
#define ll long long
using namespace std;
const int MAXN=110;
int a,b,c,d,sum,s,point[MAXN];
queue <int > q;//记录节点入度为零的点
vector<int >ve[MAXN];//邻接矩阵
void fab(){
    while(!q.empty()) q.pop();
    for(int i=1;i<=a;i++){
        if(point[i]==0){
            q.push(i);
        }
    }
    sum=0;
    while(sum<a){
        s=q.front();
        q.pop();
        sum++;
        if(sum==1){
            printf("%d",s);
        }
        else{
            printf(" %d",s);
        }
        for(int i=0;i<ve[s].size();i++){
            point[ve[s][i]]--;
            if(point[ve[s][i]]==0){
                q.push(ve[s][i]);
            }
        }
    }
}
int main(){
    while(scanf("%d%d",&a,&b)!=EOF&&(a||b)){
        for(int i=0;i<a;i++){
            ve[i].clear();
            point[i]=0;
        }
        for(int i=0;i<b;i++){
            scanf("%d%d",&c,&d);
            point[d]++;
            ve[c].push_back(d);
        }
        fab();
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
Guava Ordering是一个用于排序的工具类,它为构建复杂的比较器提供了一种流畅的风格。通过使用Guava Ordering,我们可以根据自定义的规则对集合中的元素进行排序。 在Guava Ordering中,有三种静态方法用于创建Ordering排序器:natural()、usingToString()和from(Comparator)。natural()方法使用自然排序规则生成排序器,即从小到大的顺序。usingToString()方法根据元素的toString()方法返回值进行排序。from(Comparator)方法根据给定的Comparator生成排序器。 创建Ordering排序器后,可以使用它对集合或元素进行操作。常见的方法包括sortedCopy(List)、immutableSortedCopy(Iterable)、min(E, E)和max(E, E)等。sortedCopy(List)方法返回一个已排序的List副本,immutableSortedCopy(Iterable)方法返回一个不可变的已排序集合,min(E, E)方法返回两个元素中较小的那个,max(E, E)方法返回两个元素中较大的那个。 下面是一个示例代码,展示了如何使用Guava Ordering对People类的age属性进行排序: List<People> peopleList = new ArrayList<People>() { { add(new People("A", 33)); add(new People("B", 11)); add(new People("C", 18)); } }; Ordering<People> ordering = Ordering.natural().onResultOf(new Function<People, Comparable>() { @Override public Comparable apply(People people) { return people.getAge(); } }); for (People p : ordering.sortedCopy(peopleList)) { System.out.println(MoreObjects.toStringHelper(p) .add("name", p.getName()) .add("age", p.getAge())); } 这段代码中,我们首先创建了一个包含People对象的List。然后使用Ordering.natural().onResultOf()方法创建了一个排序器,该排序器按照People对象的age属性进行排序。最后,我们通过ordering.sortedCopy()方法将集合按照排序规则进行排序,并打印排序后的结果。 通过使用Guava Ordering,我们可以轻松地实现各种排序需求,并且可以方便地链式调用方法来定制和增强现有的比较器。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺的碎冰冰~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值