Legal or Not

文章描述了一个ACM爱好者聚集的QQ群,群内成员以‘师徒’关系交流。问题在于检查这些关系是否存在非法的环,即某人既是别人的师父又是其徒弟。题目要求通过拓扑排序判断关系是否合法,若无环则输出YES,否则输出NO。给出的代码示例使用邻接矩阵和队列实现这一判断过程。
摘要由CSDN通过智能技术生成

ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input

The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output

For each test case, print in one line the judgement of the messy relationship. 
If it is legal, output "YES", otherwise "NO".

Sample Input

3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output

YES
NO

题意:就是找所建立的图中是否有环,若有输出”NO“,没有输出”YES“

这道题有一个坑点就是如何去找是否有环,基本思路就是拓扑结构用一个实数来保存入度为0的节点的个数,如果等于节点的总个数则输出”YES“,否则输出”NO“。

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<queue>
#include<vector>
#include<stack>
#define ll long long
using namespace std;
const int MAXN=150;
int a,b,c,d,sum,s;
int point[MAXN];//存每个节点的度数
vector <int > ve[MAXN];//邻接矩阵存关系
queue<int >q;//队列存入度为0的节点
void fab(){
    for(int i=0;i<a;i++){
        if(point[i]==0){
            q.push(i);
        }
    }
    sum=0;
    while(!q.empty()){
        s=q.front();
        q.pop();
        sum++;
        for(int i=0;i<ve[s].size();i++){
            point[ve[s][i]]--;
            if(point[ve[s][i]]==0 )
            q.push(ve[s][i]);
        }

    }
    if(sum==a){
        printf("YES\n");
    }
    else{
        printf("NO\n");
    }
}
int main(){
    while(scanf("%d%d",&a,&b)!=EOF&&(a&&b)){
        while(!q.empty()) q.pop();
        for(int i=0;i<a;i++){
            ve[i].clear();
            point[i]=0;
        }
        for(int i=0;i<b;i++){
            scanf("%d%d",&c,&d);
            point[d]++;
            ve[c].push_back(d);
        }
        fab();
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

旺旺的碎冰冰~

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值