HDU 1019

/*

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
  
  
105 10296
 

Source

*/

//就是求几个数的最小公倍数。输出格式要注意,第一个数是样例数,第二个数是单个样例输入个数。

//抓狂读了半天才弄懂。各种借鉴大神,最后修改类型才通过!

#include <iostream>

#include <cstdio>

using namespace std;


__int64 LCM(__int64 a,__int64 b){//求最大公倍数
    __int64 c;
    __int64 a1=a,b1=b;
    if(a<b){
        c=b;
        b=a;
        a=c;
    }
    while(b){
        c=a%b;
        a=b;
        b=c;
    }
    return (a1*b1)/a;
}

int main()
{
   int n,T;
   __int64 a[10000],result;
   scanf("%d",&T);
   while(T--){
        scanf("%d",&n);
        for(__int64 i=0;i<n;i++)
            scanf("%d",&a[i]);
        if(n==1){
            printf("%I64d\n",a[0]);
        }else{
        result=LCM(a[0],a[1]);
        for(__int64 i=2;i<n;i++)
            result=LCM(result,a[i]);
        printf("%I64d\n",result);
        }
       }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值