hdu1019(求最小公倍数要先除后乘)

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12051    Accepted Submission(s): 4410


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 


Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 


Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 


Sample Input
  
  
2 3 5 7 15 6 4 10296 936 1287 792 1
 


Sample Output
  
  
105 10296
 


#include<stdio.h>
int gcd(int a,int b)
{
 if(b==0)
  return a;
 return gcd(b,a%b);
}
int lcm(int a,int b)
{
 return a/gcd(a,b)*b;//先除后乘
}
int a[100000];
int main()
{
 int t,n,temp,i;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d",&n);
  for(i=0;i<n;i++)
   scanf("%d",&a[i]);
  temp=a[0];
  for(i=1;i<n;i++)
  {
   temp=lcm(temp,a[i]);
  }
  printf("%d\n",temp);

 }
 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值