PAT 01-复杂度2. Maximum Subsequence Sum (25)&&PAT 01-复杂度1. 最大子列和问题(20)

/*
01-复杂度2. Maximum Subsequence Sum (25)


时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue
Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.


Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.


Input Specification:


Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.


Output Specification:


For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.


Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4


主要是第5个测试点卡了好久,没弄清楚卡(=@__@=)哪里?抓狂 后来想起来是不是大数问题,数据太小,

用了__int64 ZO竟然编译不过,查了一下才知道是linux系统,懒得改太多就成下面这样了。

不过抓狂还是第5个点不过。搜了下才知道是MaxSum==0的情况下 可能是0和负数 first和last应该都为0,豁然十万只。。。。。。。

为了减少复杂度,先判断,再循环只要有0的就走人。理解题意真是硬伤。哭


*/
#include <stdio.h>
#include <stdlib.h>
#define __int64 long long
//using namespace std;
void MaxSubseqSum4( __int64 A[], int N ) {
    __int64 ThisSum, MaxSum;
    __int64 i,t1=A[N-1],t2=0,t3=0,sum2=0;
    ThisSum= MaxSum= 0;
    for( i = 0; i < N; i++ ) {
            ThisSum+= A[i]; /* 向右累加*/
    if( ThisSum> MaxSum){
        MaxSum= ThisSum; /* 发现更大和则更新当前结果*/
        t1=A[i];
        t3=i;
    }
    else if( ThisSum < 0 ) /* 如果当前子列和为负*/
        ThisSum= 0; /* 则不可能使后面的部分和增大,抛弃之*/
    }
    while(sum2!=MaxSum){
        sum2+=A[t3];
        t2=t3;
        t3--;
    }
    //判断第51种情况
    if(MaxSum==0){
        for(int i=0;i<N;i++){
            if(A[i]==0){
                t2=i;
                t1=0;
                break;
            }
        }
    }
    printf("%lld %lld %lld\n",MaxSum,A[t2],t1);
    return ;
    }


int main()
{
    __int64 a[100000];
    int k;
    while(scanf("%d",&k)!=-1){
        for(__int64 i=0;i<k;i++){
            scanf("%lld",&a[i]);
        }
        MaxSubseqSum4(a,k);
    }
    return 0;
}


//最大子列和问题(20)

/*

01-复杂度1. 最大子列和问题(20)

给定K个整数组成的序列{ N1, N2, ..., NK },“连续子列”被定义为{ Ni, Ni+1, ..., Nj },其中 1 <= i <= j <= K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{ -2, 11, -4, 13, -5, -2 },其连续子列{ 11, -4, 13 }有最大的和20。现要求你编写程序,计算给定整数序列的最大子列和。

输入格式:

输入第1行给出正整数 K (<= 100000);第2行给出K个整数,其间以空格分隔。

输出格式:

在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出0。

输入样例:
6
-2 11 -4 13 -5 -2
输出样例:
20

*/


/*
#include <iostream>
#include <cstdio>


using namespace std;
int MaxSubseqSum4( int A[], int N ) {
    int ThisSum, MaxSum;
    int i;
    ThisSum= MaxSum= 0;
    for( i = 0; i < N; i++ ) {
            ThisSum+= A[i]; // 向右累加
    if( ThisSum> MaxSum)
        MaxSum= ThisSum; // 发现更大和则更新当前结果
    else if( ThisSum< 0 ) //如果当前子列和为负
        ThisSum= 0; // 则不可能使后面的部分和增大,抛弃之
    }
    return MaxSum;
    }


int main()
{
    int a[100000],k;
    while(scanf("%d",&k)!=-1){
        for(int i=0;i<k;i++){
            scanf("%d",&a[i]);
        }
        printf("%d\n",MaxSubseqSum4(a,k));
    }
    return 0;
}


*/
题目描述 给定K个整数组成的序列{ N1, N2, ..., NK },“连续子列”被定义为{ Ni, Ni+1, ..., Nj },其中 1≤i≤j≤K。“最大子列和”则被定义为所有连续子列元素的和中最大者。例如给定序列{-2, 11, -4, 13, -5, -2},其最大子列和为20,对应子列为{ 11, -4, 13 }。 现在你应该给出一个算法,计算给定整数序列最大子列和。 输入格式 输入第1行给出正整数K(K≤10000),第2行给出K个整数,其间以空格分隔。 输出格式 在一行中输出最大子列和。如果序列中所有整数皆为负数,则输出。 输入样例 6 -2 11 -4 13 -5 -2 输出样例 20 算法1 (暴力枚举) $O(n^2)$ 暴力枚举所有的子序列,计算它们的和,最后找到最大的和即可。 时间复杂度 枚举所有子序列,时间复杂度为$O(n^2)$。 C++ 代码 算法2 (分治) $O(nlogn)$ 将序列分成左右两部分,最大序列和可能在左边、右边或者跨越中间。如果最大序列和在左边或者右边,那么可以递归求解;如果最大序列和跨越中间,那么可以分别求出左边的最大后缀和和右边的最大前缀和,然后将它们相加即可。 时间复杂度 每次递归都会将序列分成两部分,时间复杂度为$O(logn)$,而每次计算跨越中间的最大序列和的时间复杂度为$O(n)$,所以总的时间复杂度为$O(nlogn)$。 C++ 代码 算法3 (动态规划) $O(n)$ 用dp[i]表示以i结尾的最大序列和,那么dp[i]的值可以由dp[i-1]和a[i]计算得到。如果dp[i-1]是负数,那么dp[i]就是a[i];否则dp[i]就是dp[i-1]+a[i]。最后找到dp数组中的最大值即可。 时间复杂度 只需要遍历一遍数组,时间复杂度为$O(n)$。 C++ 代码
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值