Blocks(POJ-2363)

Donald wishes to send a gift to his new nephew, Fooey. Donald is a bit of a traditionalist, so he has chosen to send a set of N classic baby blocks. Each block is a cube, 1 inch by 1 inch by 1 inch. Donald wants to stack the blocks together into a rectangular solid and wrap them all up in brown paper for shipping. How much brown paper does Donald need?
Input
The first line of input contains C, the number of test cases. For each case there is an additional line containing N, the number of blocks to be shipped. N does not exceed 1000.
Output
Your program should produce one line of output per case, giving the minimal area of paper (in square inches) needed to wrap the blocks when they are stacked together.
Sample Input
5
9
10
26
27
100
Sample Output
30
34
82
54
130


题意:首先输入n,接着输入n个数字表示体积,枚举长和宽,就能计算出高,然后求所能够成矩形的最小表面积。(水题)接下来附上我AC的代码:


注意:在这道题中用到三层for循环枚举长宽高会超时,所以只能用两层。

#include <stdio.h>
#include <math.h>
#define min(a,b) a<b?a:b

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int o=1<<30;	
		int v;
		scanf("%d",&v);
		int i,j,k;
		for(i=1;i<1001;i++)
		{
			for(j=1;j<1001;j++)
			{
				k=v/i/j;
				if(i*j*k==v)
				{
					o=min(o,(i*j+i*k+j*k)*2);
				}
			}
		}
		printf("%d\n",o);
	}
	return 0;
}







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值