2120 Ice_cream's world I

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 842    Accepted Submission(s): 491


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
  
  
3
 

题意:

每组数据的第一个数表示有多少房子(编号从0~n-1),第二个数表示有多少个桥,后边有相应的数字,表示哪两个编号的房子之间有桥,求有多少个相互连通的小环.....


分析:

典型的并查集的问题,不过处理的时候特殊处理,遇到有环的时候(两个元素的的父节点相同),就累加变量加上 1 ,到最后输出这个结果.....




#include<stdio.h>
#include<string.h>
int per[1005],kase;//kase 就是累加变量,记录环的个数
void init(int n)//初始化
{
    for(int i=0;i<n;++i)
    {
        per[i]=i;
    }
}
int find(int x)//查找
{
    int r=x;
    while(per[r]!=r)
    {
        r=per[r];
    }
    int i=x,j;
    while(i!=r)//压缩
    {
        j=per[i];per[i]=r;i=j;
    }
    return r;
}
void join(int x, int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)//合并
    {
        per[fx]=fy;
    }
    else//已经连通的那么就累加变量!
    {
        ++kase;
    }
}
int main()
{
    int n,m,i,a,b;
    while(~scanf("%d%d",&n,&m))
    {
        kase=0;
        init(n);
        while(m--)
        {
            scanf("%d%d",&a,&b);
            join(a,b);//每次输入都合并一次
        }
        printf("%d\n",kase);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值