Hdu 5363 Key Set【快速幂运算】

Key Set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 533    Accepted Submission(s): 326


Problem Description
soda has a set S with n integers {1,2,,n} . A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of S are key set.
 

Input
There are multiple test cases. The first line of input contains an integer T (1T105) , indicating the number of test cases. For each test case:

The first line contains an integer n (1n109) , the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
0 1 3 7

给出一个数,求出包含 1 到这个数的集合,有多少集合内部元素的和为偶数的非空子集,输出这个数对指定的数取模的结果......

数学的集合元素的子集问题,比较简单的就可以推导出来,一共有 2 的 n-1 次方 减1个子集,然后求模.....

考察的快速幂运算求模方法,快速求幂运算,用的是二分的思想,然后对中间过程求模运用的是同余定理,这些定理和方法都是最基本的数学的方法.....


#include<stdio.h>
int main()
{
    int t,n;long long x,s;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        --n;x=2;s=1;
        while(n>=1)
        {
            x%=1000000007;
            if(n&1)//是奇数,就分离出来一个
            {
                s*=x;//单独计算那一部分
                s%=1000000007;
                --n;//减去已经计算过的
            }
            if(n)// n 如果不为零,那么一定是偶数
            {
                x=x*x;//增倍...
                n>>=1;//折半
                x%=1000000007;
            }
        }
        printf("%lld\n",s-1);//注意减 1 
    }
    return 0;
}


好丑的代码,还是按模板写一个吧....

这样就比较清爽了.....

#include<stdio.h>
#define mod 1000000007
void ksm(int a,int b)
{
    long long x=a,s=1;
    while(b>0)
    {
        if(b&1)
        {
            s=(s*x)%mod;
        }
        b>>=1;
        x=(x*x)%mod;
    }
    printf("%lld\n",s-1);
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        ksm(2,n-1);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值