1852 Ants【巧妙做法】

Ants
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12124 Accepted: 5318

Description

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207


比较巧妙的一道题,刚看到的时候也是无从下手,因为数据比较大,暴力肯定会超时,学了一种好方法,简单处理

因为所有的蚂蚁都可以看成是一样,那么在两只蚂蚁碰头的时候,可以当成两者相互穿过去了,这样一简化,想要求得最少的时间,那么就所有的蚂蚁都向离自己最远的一一端爬行,求最长的时间,就让所有的蚂蚁都向离自己最远的一端爬行,这两种情况都找到耗费时间最长的那只蚂蚁就是需要的答案。



#include<stdio.h>
#define max(a,b) (a>b?a:b)
#define min(a,b) (a<b?a:b)
int x[1000005];
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int l,n,i;
		scanf("%d%d",&l,&n);
		for(i=0;i<n;++i)
		{
			scanf("%d",x+i);
		}
		int mini=0,maxn=0;//注意初始化
		for(i=0;i<n;++i)
		{
			mini=max(mini,min(x[i],l-x[i]));//找最小
		}
		for(i=0;i<n;++i)
		{
			maxn=max(maxn,max(x[i],l-x[i]));//找最大
		}
		printf("%d %d\n",mini,maxn);
	}
	return 0;
}



参考了一下大神的做法,发现可以更简化一些....

大神就是大神!

#include<stdio.h>
#define max(a,b) (a>b?a:b)
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int l,n,i,x,mini=0,maxn=0;
		scanf("%d%d",&l,&n);
		for(i=0;i<n;++i)
		{
			scanf("%d",&x);
			x=max(x,l-x);//找出较长的
			mini=max(mini,l-x);//找短的里面最长的
			maxn=max(maxn,x);//找长的里面最长的
		}
		printf("%d %d\n",mini,maxn);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值