LightOJ 1297 Largest Box【简单计算几何】

Description

In the following figure you can see a rectangular card. The width of the card is W and length of the card is L and thickness is zero. Four (x*x)squares are cut from the four corners of the card shown by the black dotted lines. Then the card is folded along the magenta lines to make a box without a cover.

Given the width and height of the box, you will have to find the maximum volume of the box you can make for any value of x.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing two real numbers L and W (0 < L, W < 100).

Output

For each case, print the case number and the maximum volume of the box that can be made. Errors less than 10-6 will be ignored.

Sample Input

3

2 10

3.590 2.719

8.1991 7.189

Sample Output

Case 1: 4.513804324

Case 2: 2.2268848896

Case 3: 33.412886




在一块矩形的四个角分别去掉四个正方形,围城一个无盖的盒子,求最大的体积能有多大...

直接求导求极限,然后没了.....


#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
int main()
{
	int t;
	//freopen("shuju.txt","r",stdin);
	scanf("%d",&t);
	for(int k=1;k<=t;++k)
	{
		double sum=0,len,wid,x,a,b,c;
		scanf("%lf%lf",&len,&wid);
		if(len<wid)
		{
			swap(len,wid);
		}
		a=12;c=len*wid;//为了求着方便先表示出来
		b=-4*(len+wid);
		x=(-b-sqrt(pow(b,2)-4*a*c))/(2*a);
		sum=(len-2*x)*(wid-2*x)*x;
		printf("Case %d: %lf\n",k,sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值