HDU 4027 Can you answer these queries?【线段树】区间开平方,区间求和

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 11061 Accepted Submission(s): 2583


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8

Sample Output
  
  
Case #1: 19 7 6

快恶心死的一道题,本来是没看懂题意的,不小心看漏了题目,然后不知道如何下手做.....

然后最后才意识到是区间要开平方.....英语啊....

其他就是最经典的区间求和了.....

然后是一直超时.....原来是在某一区间全部取值为1 的时候,就不需要全部更新了,这样能省去很多时间的操作............

然后pe 忘了空行............

真应该涨点教训。,这样下去可就真废了..........

最近状态不好,太忙了都,好好整顿整顿吧.....



#include<stdio.h>
#include<algorithm>
#include<math.h>
using namespace std;
typedef long long ll;
ll sum[400005];int k=0;
void build(int rt,int l,int r)
{
	if(l==r)
	{
		scanf("%lld",&sum[rt]);
		return;
	}
	int mid=(l+r)>>1,tp=rt<<1;
	build(tp,l,mid);build(tp|1,mid+1,r);
	sum[rt]=sum[tp]+sum[tp|1];
}
void update(int rt,int l,int r,int a,int b)
{
	if(sum[rt]==r-l+1)//如果这个区间全部为 1 
	{
		return;
	}
	if(l==r)
	{
		sum[rt]=sqrt((double)sum[rt]);//注意
		return;
	}
	int mid=(l+r)>>1,tp=rt<<1;ll res=0;
	if(mid>=a)
	{
		update(tp,l,mid,a,b);
	}
	if(mid<b)
	{
		update(tp|1,mid+1,r,a,b);
	}
	sum[rt]=sum[tp]+sum[tp|1];
}

ll find(int rt,int l,int r,int a,int b)
{
	if(l>=a&&r<=b)
	{
		return sum[rt];
	}
	int mid=(l+r)>>1,tp=rt<<1;ll res=0;
	if(mid>=a)
	{
		res+=find(tp,l,mid,a,b);
	}
	if(mid<b)
	{
		res+=find(tp|1,mid+1,r,a,b);
	}
	return res;
}

int main()
{
	int n,m;
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d",&n))
	{
		build(1,1,n);
		printf("Case #%d:\n",++k);
		scanf("%d",&m);
		while(m--)
		{
			int kase,a,b;
			scanf("%d%d%d",&kase,&a,&b);
			if(a>b)
			{
				swap(a,b);
			}
			if(!kase)
			{
				update(1,1,n,a,b);
			}
			else
			{
				printf("%lld\n",find(1,1,n,a,b));
			}
		}
		printf("\n");
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值