Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11566 | Accepted: 8218 |
Description
In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:
0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …
An alternative formula for the Fibonacci sequence is
.
Given an integer n, your goal is to compute the last 4 digits of Fn.
Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.
Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).
Sample Input
0 9 999999999 1000000000 -1
Sample Output
0 34 626 6875
Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by
.
Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:
搁置了很久的题目,因为自己不懂矩阵的性质,不知道乘了之后会发生什么,也就根本搞不懂矩阵快速幂的方法了............
先这样吧,暂时理解还不到位,暂时记住吧,慢慢理解!
#include<stdio.h>
#include<string.h>
#define M 10000
struct matrix
{
int m[2][2];
}base,ans;
void init()
{
base.m[0][0]=base.m[0][1]=base.m[1][0]=1;
base.m[1][1]=0;
ans.m[0][0]=ans.m[1][1]=1;
ans.m[0][1]=ans.m[1][0]=0;
}
matrix mul(matrix a,matrix b)
{
matrix tp={0,0,0,0};
for(int i=0;i<2;++i)//这三层循环可以有很多种组合方法,这样的可以便于控制剪枝
{
for(int j=0;j<2;++j)
{
if(a.m[i][j]==0)
{
continue;
}
for(int k=0;k<2;++k)
{
tp.m[i][k]=(tp.m[i][k]+a.m[i][j]*b.m[j][k])%M;
}
}
}
return tp;
}
int main()
{
int n;
while(scanf("%d",&n),n!=-1)
{
init();
while(n)
{
if(n&1)
{
ans=mul(ans,base);
}
base=mul(base,base);
n>>=1;
}
printf("%d\n",ans.m[0][1]);
}
return 0;
}