HDU2138--How many prime numbers



How many prime numbers

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15910    Accepted Submission(s): 5505


Problem Description
   Give you a lot of positive integers, just to find out how many prime numbers there are.
 

Input
  There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.
 

Output
  For each case, print the number of prime numbers you have found out.
 

Sample Input
  
  
3 2 3 4
 

Sample Output
  
  
2
思路:题目大意:输入正整数n,然后输入n个数。对这些数的限制里有这么一句Each integer won’t exceed 32-bit signed integer意思是这些数有符号且不超32位。其数值表达范围为:0 ~ 4294967295数据范围不小,打表会超时,所以反过头来用最原始的办法----找有无因数。
代码:
#include<stdio.h>  
#include<math.h>  
int main()  
{  
    int t,n,flag,p,i,j,sum;  
    while(scanf("%d",&t)!=EOF)  
    {  
        sum=0;  
        for(i=0;i<t;i++)  
        {  
            scanf("%d",&n);  
            flag=1;  
            for(j=2;j<=sqrt(n);j++)  
            {  
                if(n%j==0)  
                {  
                    flag=0;  
                    break;  
                }  
            }  
            if(flag)sum++;  
        }  
        printf("%d\n",sum);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值