HDU Joseph【数学&&约瑟夫环】

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2118 Accepted Submission(s): 1285


Problem Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output
The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input
  
  
3 4 0

Sample Output
  
  
5 30

以前做过一次约瑟夫环问题,不过没太明白当时大神的最优代码,这一次又见到了类似的题,只能无脑模拟了,不过暴力模拟,很果断的TLE了.......

找大神们的解析,加深了自己的理解,不过自己还是不太明白,貌似是,利用数学技巧,动态处理了,简化了很多东西...(自己说不明白了)

然后就是打表处理了.....


#include<stdio.h> 
#include<string.h>
bool joseph(int k,int m)
{
	int bg=0,ed=k-1,tp;
	for(int n=2*k;n>k;--n)
	{
		tp=(m-1)%n;
		if(tp>=bg&&tp<=ed)
		{
			return 0;
		}
		bg=(bg-m%n+n)%n;ed=(ed-m%n+n)%n;
		//bg=((bg-m)%n+n)%n;ed=((ed-m)%n+n)%n;//同余还是理解的不够
	}
	return 1;
}
int main()
{
	int n,y[20]={0};
	for(int i=1;i<14;++i)
	{
		int j=i+1;
		while(1)
		{
			if(joseph(i,j))
			{
				y[i]=j;
				break; 
			}
			++j;
		} 
	}
	//freopen("shuju.txt","r",stdin);
	while(scanf("%d",&n),n)
	{
		printf("%d\n",y[n]);
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值