Hdu 1757 A Simple Math Problem【矩阵快速幂】

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3778 Accepted Submission(s): 2280


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.

Output
For each case, output f(k) % m in one line.

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0

Sample Output
  
  
45 104

矩阵快速幂,原本是为求解矩阵的高次幂运算的,但是在使用中,可以构造出自己需要的矩阵,来高速解决很多种计算问题,比如递推式求值,研究了这一道题,大概明白了利用矩阵求解的原理,不过理解比较浅显,需要继续努力!

矩阵的难点就在于构造矩阵了

#include<stdio.h>
#include<string.h>
int k,mod,f[10];
struct matrix
{
    int m[15][15];
    matrix operator * (const matrix &a) const//定义矩阵的乘法 
    {
        matrix tp;
        memset(tp.m,0,sizeof(tp));
        for(int i=0;i<10;++i)
        {
            for(int j=0;j<10;++j)
            {
                if(!m[i][j])//加速矩阵的运算 
                {
                    continue;
                }
                for(int k=0;k<10;++k)
                {
                    tp.m[i][k]+=m[i][j]*a.m[j][k]%mod;
                    tp.m[i][k]%=mod;
                }
            }
        }
        return tp;
    }
}base,ans;
void init()//base为构造矩阵,ans初始化为单位矩阵, 
{
    memset(base.m,0,sizeof(base.m));
    memset(ans.m,0,sizeof(ans.m));
    for(int i=0;i<10;++i)
    {
        ans.m[i][i]=1;
        base.m[i+1][i]=1;
        base.m[0][i]=f[i];
    }
}
int slove()
{
    if(k<10)
    {
        return k%mod;
    } 
    init();k-=9;
    while(k)
    {
        if(k&1)
        {
            ans=ans*base;
        }
        base=base*base;
        k>>=1;
    }
    int sum=0;
    for(int i=0;i<10;++i)
    {
        sum+=(9-i)*ans.m[0][i]%mod;
        sum%=mod;
    }
    return sum;
}
int main()
{
    //freopen("shuju.txt","r",stdin);
    while(~scanf("%d%d",&k,&mod))
    {
        for(int i=0;i<10;++i)
        {
            scanf("%d",&f[i]);
        }
        printf("%d\n",slove());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值