Poj 3187 Backward Digit Sums【暴力+排列组合】

Backward Digit Sums
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5670 Accepted: 3284

Description

FJ and his cows enjoy playing a mental game. They write down the numbers from 1 to N (1 <= N <= 10) in a certain order and then sum adjacent numbers to produce a new list with one fewer number. They repeat this until only a single number is left. For example, one instance of the game (when N=4) might go like this: 

    3   1   2   4

      4   3   6

        7   9

         16
Behind FJ's back, the cows have started playing a more difficult game, in which they try to determine the starting sequence from only the final total and the number N. Unfortunately, the game is a bit above FJ's mental arithmetic capabilities. 

Write a program to help FJ play the game and keep up with the cows.

Input

Line 1: Two space-separated integers: N and the final sum.

Output

Line 1: An ordering of the integers 1..N that leads to the given sum. If there are multiple solutions, choose the one that is lexicographically least, i.e., that puts smaller numbers first.

Sample Input

4 16

Sample Output

3 1 2 4

Hint

Explanation of the sample: 

There are other possible sequences, such as 3 2 1 4, but 3 1 2 4 is the lexicographically smallest.


题意:

给出n和s,问怎么安排数字1-n的顺序能使得得到的序列按上述方式相加后,得到的和为s,数据确保有解,多个解只输出字典序最小的。


题解:

和排列组合有关,因此需要先枚举出所有的排列方式,进而才能进行下一步判断,尝试样例不难发现

如果有n 个数,那么第m (0<m<=n)个数前面需要乘的系数是第(n-1) 阶的杨辉三角的系数,也就是组合数,那么在进行处理前,可以事先计算好系数,然后进行暴力枚举计算,直到满足条件的时候输出序列。

例如: n=4,四项的系数分别是 1,3,3,1,n=5时,对应 1,4,6,4,1,


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int table[105];
int C(int n,int m)//计算组合数
{
	if(m>n-m)
	{
		m=n-m;
	}
	int tp=1;
	for(int i=n;i>n-m;--i)
	{
		tp*=i;
	}
	for(int i=m;i>1;--i)
	{
		tp/=i;
	}
	return tp;
}
int ok(int x[],int n)//判断是否符合要求
{
	int sum=0;
	for(int i=0;i<n;++i)
	{
		sum+=(x[i]*table[i]);
	}
	return sum;
}
int main()
{
	int n,m,x[105];
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=0;i<n;++i)
		{
			table[i]=C(n-1,i);//计算出系数
			x[i]=i+1;//数组赋值
		}
		do
		{
			if(ok(x,n)==m)
			{
				printf("%d",x[0]); 
				for(int i=1;i<n;++i)
				{
					printf(" %d",x[i]);
				} 
				printf("\n");
				break;
			}
		}while(next_permutation(x,x+n));//暴力枚举排列组合所有的情况
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值