Hdu 5630 Rikka with Chess【水】

Rikka with Chess


Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Yuta gives Rikka a chess board of size 

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors. 

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa. 

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input

The first line contains a number   ――The number of the testcases. 

Each testcase contains two numbers 
 

Output

For each testcase, print a single number which represents the answer.
 

Sample Input

     
     
3 1 2 2 2 3 3
 

Sample Output

     
     
1 2 2
 


题意:

给出n*m 的棋盘(类似于国际象棋的棋盘),上下左右相邻的格子颜色不同(黑和白),有一个人可以一次操作任意规格矩形内的格子,使得其颜色变成另一种颜色,问这个人想把棋盘操作成只有一种颜色,最少需要操作几次


题解:

根据图形的特殊性,每次只操作一行或者一列才可能最优,不难发现,每次操作的话,最少需要n/2次 行的操作,就能使得所有相同颜色的在同一列,然后对m/2列进行操作,既能使得所有的格子颜色相同。


#include<stdio.h>
#include<string.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		printf("%d\n",n/2+m/2);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值