Poj 3181 Dollar Dayz【整数划分+大数】

Dollar Dayz
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5679 Accepted: 2130

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

Source


题意:

给出一个数N,问将其划分为不超过M的若干个非零数的种类数


题解:

弄清题意之后,就明白是划分整数dp了...

不过超出了64位的范围,需要进行大数模拟运算.....

然而自己并不太懂...


/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
int dp[1005][30];
void add(int a,int b)
{
	for(int i=0;i<30;++i)
	{
		dp[a][i]+=dp[b][i];
		if(dp[a][i]>=10000)
		{
			++dp[a][i+1];
			dp[a][i]%=10000;
		}
	}
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		memset(dp,0,sizeof(dp));
		dp[0][0]=1;
		for(int i=1;i<=m;++i)
		{
			for(int j=i;j<=n;++j)
			{
				add(j,j-i);
			}
		}
		int kase=25;
		while(kase>0&&!dp[n][kase])
		{
			--kase;
		}
		printf("%d",dp[n][kase]);
		for(int i=kase-1;i>=0;--i)
		{
			printf("%04d",dp[n][i]);
		}
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值