Poj 2392 Space Elevator【多重背包】

Space Elevator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10334 Accepted: 4916

Description

The cows are going to space! They plan to achieve orbit by building a sort of space elevator: a giant tower of blocks. They have K (1 <= K <= 400) different types of blocks with which to build the tower. Each block of type i has height h_i (1 <= h_i <= 100) and is available in quantity c_i (1 <= c_i <= 10). Due to possible damage caused by cosmic rays, no part of a block of type i can exceed a maximum altitude a_i (1 <= a_i <= 40000). 

Help the cows build the tallest space elevator possible by stacking blocks on top of each other according to the rules.

Input

* Line 1: A single integer, K 

* Lines 2..K+1: Each line contains three space-separated integers: h_i, a_i, and c_i. Line i+1 describes block type i.

Output

* Line 1: A single integer H, the maximum height of a tower that can be built

Sample Input

3
7 40 3
5 23 8
2 52 6

Sample Output

48

Hint

OUTPUT DETAILS: 

From the bottom: 3 blocks of type 2, below 3 of type 1, below 6 of type 3. Stacking 4 blocks of type 2 and 3 of type 1 is not legal, since the top of the last type 1 block would exceed height 40.

Source


题意:

有k 种石头,给出每种石头的高度h,以及每种石头能放到的最大高度a(这个条件有点奇怪),每种石头的数量c,问最高可以堆积多高


题解:

首先按限制的高度排序,然后就转变成多重背包求最高了,当然要加上题目要求的条件控制

多重背包,最直观的还是转化为01背包的做法求,传说中有一个单调队列优化的算法,正在学习中.......


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int h,a,c;
}x[505];
int dp[50005];
int cmp(node a,node b)
{
	return a.a<b.a;//先按限制高度排序
}
int slove(int n)
{
	sort(x,x+n,cmp);
	memset(dp,0,sizeof(dp));
	int ans=0;
	for(int i=0;i<n;++i)	
	{
		for(int j=x[i].a;j>=x[i].h;--j)
		{
			int num=min(x[i].c,j/x[i].h);//最大可使用数量
			for(int k=0;k<=num;++k)
			{
				int tp=dp[j-k*x[i].h]+k*x[i].h;
				if(x[i].a>=tp)//高度条件控制
				{
					dp[j]=max(tp,dp[j]);
				}
			}
			ans=max(ans,dp[j]);
		}
	}
	return ans;
}
int main()
{
	int n;
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d%d%d",&x[i].h,&x[i].a,&x[i].c);
		}
		printf("%d\n",slove(n));
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值