Poj 2184 Cow Exhibition【01背包 变形】

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11276 Accepted: 4475

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 

Source


题意:

给出每头牛的智商和情商,现要选出一些奶牛,使得总的智商和情商都大于0,问能求得的智商和情商的值的和最大为多少。


题解:


看到这个题,首先想到的是01 背包,但是感觉好奇怪啊,竟然有负的怎么搞,而且貌似没有容积那个属性限制啊..........

死掉很多脑细胞后,终于搜了大神的博客,发现确实是01 背包,不过需要变形一下,不但要整体平移,还要考虑正负的情况,瞬间感觉自己连01背包都没理解透彻....

感觉再也不会爱dp了.....


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=0x3f3f3f3f;
int x[105],y[105];
int dp[200005];
int slove(int n)
{
	int m=100000;//找一个中间位置 
	fill(dp,dp+200005,-maxn);
	dp[m]=0;
	for(int i=0;i<n;++i)
	{
		if(x[i]<0&&y[i]<0)//无效的直接抛弃 
		{
			continue;
		}
		if(x[i]>0)//大于零的正向01 背包 
		{
			for(int j=2*m;j>=x[i];--j)
			{
				if(dp[j-x[i]]>-maxn)
				{
					dp[j]=max(dp[j],dp[j-x[i]]+y[i]);
				}
			}
		}
		else//反向01背包 
		{
			for(int j=x[i];j<=2*m+x[i];++j)
			{
				if(dp[j-x[i]]>-maxn)
				{
					dp[j]=max(dp[j],dp[j-x[i]]+y[i]);
				}
			}
		}
	}
	int ans=-maxn;
	for(int i=m;i<=2*m;++i)
	{
		if(dp[i]>=0)
		{
			ans=max(ans,dp[i]+i-100000);
		}
	}
	return ans;
}
int main()
{
	int n;
	//freopen("shuju.txt","r",stdin);
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;++i)
		{
			scanf("%d%d",&x[i],&y[i]);
		}
		printf("%d\n",slove(n));
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值