Poj 1703 Find them, Catch them【关系并查集】

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39668 Accepted: 12192

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


题意:

给出n个人,编号1-n。每个人都可能属于两个组织的某一个,m组操作,D a b 表示 a b 属于不同的组,A a b 询问两者之间的关系,输出对应的结果


题解:

首先想到的是并查集,但是并查集只能记录某两个元素是否属于同一个集合,并表示不了相互之间的关系,需要重新加入一个关系数组,记录每个节点和他相连的根的节点是否是同一个组织 ,并在查找的时候,实现路径压缩,否则会超时...


r 数组:

0 表示元素与根不是同一个组织,1 表示是同一个组织


个人并不会,借鉴的大神的代码,确实不太理解.....


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1e5+5;
int pre[maxn],r[maxn];
void init(int n)//这是初始化
{
	memset(r,0,sizeof(r));
	for(int i=1;i<=n;++i)
	{
		pre[i]=i;
	}
}
int find(int x)
{
	if(pre[x]==x)
	{
		return x;
	}
	int t=pre[x];//这是他的父节点当前的值
	pre[x]=find(pre[x]);//递归找根
	r[x]=(r[x]==r[t])?0:1;//不太懂
	return pre[x];//根
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m;
		scanf("%d%d",&n,&m);
		init(n);
		for(int i=0;i<m;++i)
		{
			char s[5];int x,y;
			scanf("%s%d%d",s,&x,&y);
			int fx=find(x),fy=find(y);
			if(s[0]=='A')
			{
				if(fx!=fy)//没有联系过
				{
					printf("Not sure yet.\n");
				}
				else if(r[x]==r[y])//同一类
				{
					printf("In the same gang.\n");
				}
				else
				{
					printf("In different gangs.\n");
				}
			}
			else
			{
				if(fx!=fy)
				{
					pre[fx]=fy;
					r[fx]=(r[x]==r[y])?1:0;
				}
			}
		}
	} 
	return 0;
}


另一种处理方式,效果一样,只是个人不是太理解.........

感觉高大上,数据结构太灵活.....

/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
const int maxn=1e5;
int pre[maxn],r[maxn];
void init(int n)
{
	memset(r,0,sizeof(r));
	for(int i=1;i<=n;++i)
	{
		pre[i]=i;
	}
}
int find(int x)
{
	if(x==pre[x])
	{
		return x;
	}
	int fx=find(pre[x]);
	r[x]=(r[x]==r[pre[x]])?0:1;
	return pre[x]=fx;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,m; 
		scanf("%d%d",&n,&m);
		init(n);
		for(int i=0;i<m;++i)
		{
			char s[10];int x,y;
			scanf("%s%d%d",s,&x,&y);
			int fx=find(x),fy=find(y);
			if(s[0]=='A')
			{
				if(fx!=fy)
				{
					printf("Not sure yet.\n");
				}
				else if(r[x]==r[y])
				{
					printf("In the same gang.\n");
				}
				else
				{
					printf("In different gangs.\n");
				}
			}
			else
			{
				if(fx!=fy)
				{
					pre[fx]=fy;
					if(r[y]==0)
					{
						r[fx]=1-r[x];
					}
					else
					{
						r[fx]=r[x];
					}
				}
			}
		}
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值