A - Happy 2004 HDU - 1452 (逆元)

Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29). 

 

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6. 

Input

The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

 

A test case of X = 0 indicates the end of input, and should not be processed. 

Output

For each test case, in a separate line, please output the result of S modulo 29. 

Sample Input

1100000

Sample Output

610

举个例子:12的因子和为:1+2+3+4+6+12
计算方法是把12分解为质因数的表达形式2^2*3
那么他的因子和就是:(1+2+2^2)*(1+3)  因子个数是(2+1)*(1+1)=6

数论知识就是。。。扩展欧几里得求逆元;求出了神圣的“9”

#include<stdio.h>
#include<string.h>
//int exgcd(int a,int b,int &x,int &y)
//{
//	if(b==0)
//	{
//		x=1;y=0;return a;
//	 } 
//	 int r=exgcd(b,a%b,x,y);
//	 int tmp=x;x=y;y=tmp-a/b*y;
//	 return r;
// } 
 long long kuai(long long a,long long b)
 {
 	long long x=1;a=a%29;
 	while(b>0)
 	{
 		if(b%2==1)
 		x=(x*a)%29;
 		b=b/2;a=a*a%29;
	 }
	 return x;
 }
 int main()
 {
// 	int x,y;
// 	int k=exgcd(332,29,x,y);332是2*166=(2-1)*(3-1)*(167-1)等比公式
 	long long t;
 	while(scanf("%lld",&t),t!=0)
 	{
 		long long ans=(kuai(2,2*t+1)-1)*(kuai(3,t+1)-1)*(kuai(167,t+1)-1)*9%29;
 		printf("%lld\n",ans);
	 }
 	return 0;
 }

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值