HDU 1452:Happy 2004【唯一分解定理+积性函数】

Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

A test case of X = 0 indicates the end of input, and should not be processed.

Output
For each test case, in a separate line, please output the result of S modulo 29.

Sample Input
1
10000
0

Sample Output
6
10

题意
求2004的x次方的所有因子的和模 292929 的值。

思路
根据唯一分解定理:
任何一个数都可以写成:

a=(p1^c1)*(p2^c2)*......*(pn^cn)

所以所有的因子和为:

sum=(p1^0+p1^1+...+p1^c1)*(p2^0+p2^1+...+p2^c2)*...*(pn^0+pn^1+...+pn^cn)
   =((p1^(c1+1)-1)/(p1-1))*((p2^(c2+1)-1)/(p2-1))*...*((pn^(cn+1)-1)/(pn-1))

2004的基础因子,只有:2,3,167,三个
所以:

2004^n=2^2*n)*3^n*167^n;

所以2004^n的因子和为:

sum=((2^(2*n+1)-1)/(2-1))*((3^(n+1)-1)/(3-1))*((167^(n+1)-1)/(167-1))

AC代码

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;

ll qmi(ll m, ll k, ll p)
{
    ll res=1%p,t=m;
    while(k)
    {
        if (k&1)
            res=res*t%p;
        t=t*t%p;
        k>>= 1;
    }
    return res;
}

ll inv(ll a, ll p) 
//费马求a关于b的逆元
{
    return qmi(a, p-2, p);
}

int n;
int ans,a,b,c;

int main()
{
    while (scanf("%d",&n) && n)
    {
        a=(qmi(2,2*n+1,29)-1)*inv(1,29);
        b=(qmi(3,n+1,29)-1)*inv(2,29);
        c=(qmi(167,n+1,29)-1)*inv(166,29);
        ans=a*b*c%29;
        cout<<ans<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值