PAT 1003. Emergency (25)<最短路径,最大搜救人数>

1003. Emergency (25)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.


Input


Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.


Output


For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.


Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
Sample Output
2 4
1 dist 利用dijkstra算法,求出dist[d]的最短距离
2 max  在求最短距离的过程中(动态的)保存最大搜救人数,即两个路径相等时判断人数
3 def  初始化各点的路径条数为1,如果发现最短路有相等的就相加,如果存在<就是路径数的传递 
*/

#include<iostream>
#include<string.h>
using namespace std;
int main()
{
	int a,b,c,d;				//开始保存数据 
	cin>>a>>b>>c>>d;
	int *arr=new int[a];
	for(int i=0;i<a;i++)
	cin>>arr[i];
	int **map=new int*[a];//new 二维数组 
	for(int i=0;i<a;i++)
	map[i]=new int[a];
	
	for(int ji=0;ji<a;ji++)
	for(int jj=0;jj<a;jj++)
	if(ji==jj)map[ji][jj]=0;
	else
	map[ji][jj]=100000000;

	for(int i=0;i<b;i++)
	{
		int a1,b1;
		cin>>a1>>b1;
		int c1;cin>>c1;
		map[a1][b1]=c1;
		map[b1][a1]=c1;
		
	}					   //完成保存数据
	int *mark=new int[a]();//是否访问 
	int *dist=new int[a]();//最短路径 
	int *max=new int[a](); //记录最大的救援人数 
	int *def=new int[a];   //记录路径的数量 
	
	//初始化dist
	for(int i=0;i<a;i++)
	{
		def[i]=1;		
		dist[i]=map[c][i];
		max[i]=arr[i];
	} 
	mark[c]=1;
	//开始查找每一个dist数据 
	for(int i=0;i<a;i++) 
	{	
		if(i==c)continue;
		//找到dist的第一个最小值
		int min=100000000,flag; 
		for (int j=0;j<a;j++)
		{
			if(mark[j]==0&&dist[j]<min)
			{
				min=dist[j];
				flag=j;
			}
		}
		mark[flag]=1;
		if(flag==d)break;
		//更新dist dist,max,def 
		for(int j=0;j<a;j++)
		{
			if(mark[j]==0&&dist[flag]+map[flag][j]<dist[j]) 
			{
				dist[j]=dist[flag]+map[flag][j];
				max[j]=max[flag]+arr[j];
				def[j]=def[flag]; 
			}
			else if(mark[j]==0&&dist[flag]+map[flag][j]==dist[j])//关键操作 
			{
				def[j]+=def[flag];				//路径相加 
				if(max[flag]+arr[j]>=max[j])
				{
					max[j]=max[flag]+arr[j];
				}
				
			}
			
		}
	}
	if(c==d)
	max[d]=0;
	cout<<def[d]<<" "<<max[d]+arr[c];
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值