hdu 1025(DP)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1025

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15902    Accepted Submission(s): 4537


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
  
  
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
  
  
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.
思路: (1)刚开始做这道题的时候并没意识到是 最长上升子序列,然后用普通dp思想去做,发现会超时,做不下去,然后看了看题解,就学会了另外一种求解最长上升子序列的算法  时间复杂度为O(n*logn)用了二分查找~做这道题之前可以先看看poj的3903,把那道题弄会了,这道题就会了;http://blog.csdn.net/liusuangeng/article/details/38899155

              (2)回到这题,我们用一个结构体存Line I中的n个数 和 Line II中的n个数 ,然后按照Line I 中的n个数从小到大将结构体排序,那么此时在Line II中去找最长上升子序列即可。

               ( 3 )最后说一下 这题中的一个坑,输出road 和roads 是有区别的

                PS:先做POJ3903,再做这题~~~~

               附上代码;

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cmath>
const int maxn=500500;
const int INF=99999999;
using namespace std;

struct node
{
  int s,e;
}a[maxn];

int d[maxn];

int cmp(node a,node b)
{
  return a.s<b.s;
}

int find(int l,int r,int key)
{
   if(l==r)return l;
   int mid=(l+r)/2;
   if(key>d[mid])return find(mid+1,r,key);
   else return find(l,mid,key);
}

int main()
{
        int n,test=1;
        while(scanf("%d",&n)!=EOF)
        {
          for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].s,&a[i].e);
          sort(a,a+n,cmp);
          int len=0;
          d[0]=-INF;

          for(int i=0;i<n;i++)
          {
            if(a[i].e>d[len])d[++len]=a[i].e;
            else
            {
                int j=find(1,len,a[i].e);
                d[j]=a[i].e;
            }
          }
          if(len==1||len==0)
          printf("Case %d:\nMy king, at most %d road can be built.\n\n",test++,len);
          else
          printf("Case %d:\nMy king, at most %d roads can be built.\n\n",test++,len);

        }
        return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值