poj 3278 Catch That Cow

题目链接:http://poj.org/problem?id=3278

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 47168 Accepted: 14818

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

思路:广搜入门题;

         (1)广搜运用一个队列让所有可行节点入队,然后再一个个出队判最优解;

         (2)这道题用数组模拟队列~~~=。=

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <cstdio>
#include <cmath>
const int maxn=101000;
using namespace std;
int vis[maxn*2],que[maxn*2],d[maxn*2];
int n,k;
void bfs(int x)
{
    memset(vis,0,sizeof(vis));
    memset(que,0,sizeof(que));
    memset(d,0,sizeof(d));
    vis[x]=1;
    int front=0,rear=0;
    que[rear++]=x;
    while(front<rear)
    {
        x=que[front++];
        if(x==k)return;  //广搜出口
        //下面剪支 
        if(!vis[x-1]&&x>0) {vis[x-1]=1;que[rear++]=x-1;d[x-1]=d[x]+1;}  
        if(!vis[x+1]&&x<100000) {vis[x+1]=1;que[rear++]=x+1;d[x+1]=d[x]+1;}
        if(!vis[2*x]&&2*x>=0&&2*x<=100000) {vis[2*x]=1;que[rear++]=x*2;d[x*2]=d[x]+1;}
    }
}

int main()
{
        while(cin>>n>>k)
        {
           bfs(n);
           cout<<d[k]<<endl;
        }
        return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值