zoj 3822概率dp

Domination


Time Limit: 8 Seconds Memory Limit: 131072 KB Special Judge


Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What’s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

“That’s interesting!” Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input
There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output
For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input
2
1 3
2 2

Sample Output
3.000000000000
2.666666666667

分析: 这是2014年牡丹江现场赛一题==
可以顺着推概率,最后E=p1*n1+p2*n2…..
也可以逆着推期望。

我用的是dp[i][j][k]表示有i行,j列在第k天被控制好了。
那么当第k+1天放棋子的时候就有四种状态转移;
dp[i][j][k+1]*p1
dp[i+1][j][k+1]*p2
dp[i][j+1][k+1]*p3
dp[i+1][j+1][k+1]*p4
这里的概率分别求就行~

#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
const int N=66*66;
using namespace std;
int n,m;
double dp[55][55][N];
//dp[i][j][k]表示有i行满足每行至少有一个棋子的条件,有j列满足每列至少有一个棋子的条件,共占据了K个格子

int main()
{
   int T;
   scanf("%d",&T);
   while(T--)
   {
     scanf("%d%d",&n,&m);
     int total=n*m;
     memset(dp,0,sizeof(dp));
     dp[1][1][1]=1.0;

     for(int i=1;i<=n;i++)
       for(int j=1;j<=m;j++)
        for(int k=max(i,j);k<=i*j;k++)
        {
             if(i==n && j==m)break;
             //cout<<i<<" "<<j<<" "<<k<<"  ";
             //printf("%.12lf\n",dp[i][j][k]);
             if(k!=i*j)dp[i][j][k+1]+=(i*j-k)*1.0/(total-k)*dp[i][j][k];
             if(j+1<=m)
             {
              //cout<<i<<" "<<j<<" "<<k<<"  ";
              dp[i][j+1][k+1]+=(i*m-i*j)*1.0/(total-k)*dp[i][j][k];
              // printf("%.12lf\n",dp[i][j+1][k+1]);

             }

             if(i+1<=n)
             {
                dp[i+1][j][k+1]+=(j*n-i*j)*1.0/(total-k)*dp[i][j][k];
             }
             if(i+1<=n && j+1<=m)
             {
              dp[i+1][j+1][k+1]+=(total-i*m-j*n+i*j)*1.0/(total-k)*dp[i][j][k];
             }
        }

        int cnt=max(n*(m-1),m*(n-1))+1;
        double ans=0.0;
        for(int i=max(n,m);i<=cnt;i++)
        {
               ans+=dp[n][m][i]*i;
               //cout<<n<<" "<<m<<" "<<i<<"  ";
               //printf("%.12lf\n",dp[n][m][i]);
               //printf("%.12lf\n",ans);
        }
        printf("%.12lf\n",ans);
   }
   return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值